Car Questions

Notifications
Clear all

2012 Honda CRV with P0341 Code

   RSS

0
Topic starter

P0341 “Camshaft Position Sensor A Circuit range Performance Bank 1 or single sensor”

My daughter has this 2012 CRV with about 304,000 kms. Recently her Check Engine Light came on and my Blue Driver pull the codes P0341 and 2 Electronic Steering codes 85-01 VGA Signal Failure and 11-02 IG1 Power Line Failure. When I cleared the codes using the clearing of all systems not just the codes, then they all disappeared. Sounds good but shortly afterwards the code P0341 appeared in the permanent codes list but not the Trouble code list. After about 500 kms the check engine light went on revealing the P0341 code in both places the Trouble codes only and the permanent codes. I of course cleared the trouble code but the permanent code remained. The engine does not stall or run roughly in any way: it’s as smooth as silk. Any ideas! Do I have to replace 1 or both cam sensors or ignore at this time??

2 Answers
2

First I would change the engine oil and filter dirty oil will off and trip that on those cars. If not I would replace the actuators solenoid that's what usually goes bad if it's changing the oil doesn't fix it

0
Topic starter

Scotty:

took your advice to change the oil and the P0341 did come back. My questions is that The CRV has 2 Cam sensors and Blue Driver highlights Bank 1. Is that the front or rear sensor or Both? Local Honda dealer charges $C127 per sensor? Is it wrong to find a cheaper after market sensor? Any suggestions of good supplier if any?

ted

 

I think you have a 2.4L 4 cylinder engine so you only have 1 cylinder bank (Bank 1)
.
The part of the code which tells you which cam sensor it's referring to is the " Sensor A Circuit"
.
That's the intake cam's sensor
.
But you'd be wasting your money replacing that cam sensor because it's likely telling the truth
.
The problem isn't the cam sensor
.
Like Scotty said, it's likely the actuator solenoid

Share: