Car Questions

Notifications
Clear all

Very bad fuel consumption

   RSS

0
Topic starter

Hello! I'm almost tired of figuring out what is happening inside my car.

I have a W203 V6 C230 Sport 2007.

I have no fault codes on the engine or the transmission. But, Here are some apparent symptoms that I'm facing:

  • I am facing a hurting/ugly smell out of the exhaust (not all the time but especially in the first start).
  • Facing hard starting up when I start the car at the beginning of the day (temp here is around 20°C).
  • Very poor fuel consumption! This engine should consume about 160 km in the city per tank. It really does go 100 km max!
  • Sometimes, some hesitation.

After hard and deep research, I'm almost sure that my problem is the Mass Air Flow Sensor (MAF). I ordered a cleaning spray, but haven't received it yet. But with this post and the attached pictures of the live data (Please see the links), what do you think is the solution to the problem?

I also have thought, as long as the O2 sensors are giving results, does this mean that they are working properly?

Data stream results:

2 Answers
1
Posted by: @ahmad_sh

This engine should consume about 160 km in the city per tank.

https://www.ultimatespecs.com/car-specs/Mercedes-Benz/1364/Mercedes-Benz-W203-Class-C-230.html

That's about 40l/100km, total overdose. How many km does it have?

Believe me not more than 100km per 20L.

For normal driving, that is too much.

1
Posted by: @ahmad_sh

I am facing a hurting/ugly smell out of the exhaust (not all the time but especially in the first start).

Posted by: @ahmad_sh

Facing hard starting up when I start the car at the beginning of the day (temp here is around 20°C).

Sometimes, some hesitation

https://carkiller.com/scottykilmer/qa/why-is-my-car-hard-to-start/

https://carkiller.com/scottykilmer/qa/car-hard-start/

Posted by: @ahmad_sh

Very poor fuel consumption!

Share: