Car Questions

Notifications
Clear all

2006 Hyundai Accent GLS automatic electric and roll back problem

   RSS

0
Topic starter

So I have a 2006 Hyundai Accent GLS 4D Sedan. The engine has 156,000 miles on it and it is not in great condition. The engine does not have any knocks but it does have heavy wear to the cylinders. This is due to the engine being ran low on oil. It was low not without oil. It was using 5W-20 before and now I can't even put that in the engine because it burns off 2 quarts a day of 5W-20. So I use 10W-30 with a special oil added to it. It is a green oil. I'll add the name later. I now burn one quart of that off in 6-7 days which is less costly. 

 

The engine is on its last leg and it has been for the last 2,000 miles I've driven it. There are a few issues I was curious about.

 

1. The car rolls backwards sometimes off and on depending on if the engine is warmed up or not. Though it does it when the engine is cold too sometimes but more so when hot and after being run for about an hour. This is an automatic transmission not a manual. 

 

Why does it roll back and keep rolling back? Isn't due to the engine wearing out?

 

2. My first issue I started having was when I would turn my lights off, the switch would be in the off position but my dash lights and Amber's are fully on. It takes one time of turning the lights on and then off to turn them off. But it didn't do that originally.

 

What is that maybe caused by? The engine wearing out or a faulty or worn out switch?

 

3. The 3rd problem is that my AC will turn on but the fans will not turn on. My heat will work but the fans won't blow to push the hot air through. From time to time it works. Like it'll go about 30 minutes to an hour not working and then all of a sudden it just starts working again while I'm driving. But then eventually stops working again. Typically after I get out of my car to go shop and then come right back while the engine is still warm it stops working. If I park my car overnight it fixes itself for some reason the next day. I've looked at all fuses and relays, fuses aren't blown and have a good connection and relays are good as well. 

 

Why would the AC compressor work but not the fans for both heat and cold? Is it related to the engine wearing out?

 

Any help would be greatly appreciated because I'm stumped. 

1 Answer
2
Posted by: @scottsm9522

1. The car rolls backwards sometimes off and on depending on if the engine is warmed up or not.

That's an issue with transmission and not related to the engine. 

 

Posted by: @scottsm9522

2. My first issue I started having was when I would turn my lights off, the switch would be in the off position but my dash lights and Amber's are fully on.

https://www.hyundaiforum.com/forum/hyundai-accent-16/parking-lights-wont-shut-off-5711/

 

Posted by: @scottsm9522

3. The 3rd problem is that my AC will turn on but the fans will not turn on. My heat will work but the fans won't blow to push the hot air through.

Are you referering to the cooling fans or the blower motor inside the cabin?

The blower motor. The cooling fans are working properly to cool the engine.

It could be either the resistor or the blower motor itself. When it does not work, if you put the fan on full blast, does it make it work again?

No. When I put the fans on full blast it doesn't work. This particular car seems to allow air in a little depending on how fast you drive. Probably from air being pushed through from the air outside. It will come out hot or cold depending on where where dial is set when the fans are OFF.
It does this normally, but it seems to allow more air through at faster speeds than it did before. Not sure why this is. But no it doesn't work at full blast or any of the settings. Air is let through though at fast speeds when the valve, flap or vent is open. (Set to either frontal, or Any of the settings for air direction)

Share: